Difference between revisions of "Working with 3D models"

From ElphelWiki
Jump to: navigation, search
(Created page with "==<font color='blue'>Original file format</font>== * '''*.x3d''' ==<font color='blue'>Programs</font>== * MeshLab * CloudCompare * Blender ==<font color='blue'>Convert to o...")
 
(View)
(9 intermediate revisions by the same user not shown)
Line 1: Line 1:
 
==<font color='blue'>Original file format</font>==
 
==<font color='blue'>Original file format</font>==
* '''*.x3d'''
+
* '''*.x3d''' (<font color='red'>download the textures that are stored in separate files</font> - the paths are specified inside x3d, usually just the file names = same directory)
  
 
==<font color='blue'>Programs</font>==
 
==<font color='blue'>Programs</font>==
Line 10: Line 10:
 
==<font color='blue'>Convert to other 3D formats</font>==
 
==<font color='blue'>Convert to other 3D formats</font>==
 
* MeshLab:  
 
* MeshLab:  
** File > Export Mesh As... supports a few formats: '''*.3ds''', '''*.ply''', '''*.stl''', '''*.obj''', '''*.dxf''', '''*.dae''', '''*.xyz''', etc.
+
** ''File > Export Mesh As...'' supports a few formats: '''*.3ds''', '''*.ply''', '''*.stl''', '''*.obj''', '''*.dxf''', '''*.dae''', '''*.xyz''', etc.
  
 
* Blender:
 
* Blender:
 
** Supports some x3d files but not all
 
** Supports some x3d files but not all
  
===CloudCompare===
+
==<font color='blue'>View</font>==
* No x3d support
 
 
 
==<font color='blue'>Viewing</font>==
 
 
===MeshLab===
 
===MeshLab===
* Open *.x3d
+
* Open '''*.x3d'''
 
Notes:
 
Notes:
 
* Lights off
 
* Lights off
 
* Couldn't adjust proper camera settings
 
* Couldn't adjust proper camera settings
 
===Blender===
 
===Blender===
* Convert to *.obj in MeshLab
+
* Convert to '''*.obj''' in MeshLab
* File > Import > Wavefront (.obj)
+
* ''File > Import > Wavefront (.obj)''
 +
*
 
===CloudCompare===
 
===CloudCompare===
* Convert to *.obj in MeshLab
+
* Convert to '''*.obj''' in MeshLab
* Drag and drop *.obj into the CloudCompare window
+
* Drag and drop '''*.obj''' into the CloudCompare window
* Options > Display parameters > Colors and Materials > set all lights to white
+
* ''Options > Display parameters > Colors and Materials >'' set all lights to white
* Options > Camera parameters > set Camera/Eye center and fov
+
* ''Options > Camera parameters >'' set Camera/Eye center and fov

Revision as of 13:15, 28 July 2017

Original file format

  • *.x3d (download the textures that are stored in separate files - the paths are specified inside x3d, usually just the file names = same directory)

Programs

  • MeshLab
  • CloudCompare
  • Blender

Convert to other 3D formats

  • MeshLab:
    • File > Export Mesh As... supports a few formats: *.3ds, *.ply, *.stl, *.obj, *.dxf, *.dae, *.xyz, etc.
  • Blender:
    • Supports some x3d files but not all

View

MeshLab

  • Open *.x3d

Notes:

  • Lights off
  • Couldn't adjust proper camera settings

Blender

  • Convert to *.obj in MeshLab
  • File > Import > Wavefront (.obj)

CloudCompare

  • Convert to *.obj in MeshLab
  • Drag and drop *.obj into the CloudCompare window
  • Options > Display parameters > Colors and Materials > set all lights to white
  • Options > Camera parameters > set Camera/Eye center and fov