Difference between revisions of "Working with 3D models"

From ElphelWiki
Jump to: navigation, search
(Blender)
(3 intermediate revisions by the same user not shown)
Line 1: Line 1:
 
==<font color='blue'>Original file format</font>==
 
==<font color='blue'>Original file format</font>==
 
* '''*.x3d''' (<font color='red'>download the textures that are stored in separate files</font> - the paths are specified inside x3d, usually just the file names = same directory)
 
* '''*.x3d''' (<font color='red'>download the textures that are stored in separate files</font> - the paths are specified inside x3d, usually just the file names = same directory)
 +
** to download a sample, visit [https://community.elphel.com/3d+map/ 3d+map] - open 3d scene then click the '''download''' button.
  
 
==<font color='blue'>Programs</font>==
 
==<font color='blue'>Programs</font>==
Line 27: Line 28:
 
* Convert to '''*.obj''' in MeshLab
 
* Convert to '''*.obj''' in MeshLab
 
* ''File > Import > Wavefront (.obj)''
 
* ''File > Import > Wavefront (.obj)''
*  
+
* Switch '''viewport shading''' to '''texture''' (in ''Default view'' it's located next to the ''Object mode'')
 +
 
 
===CloudCompare===
 
===CloudCompare===
 
* Convert to '''*.obj''' in MeshLab
 
* Convert to '''*.obj''' in MeshLab

Revision as of 11:19, 31 July 2017

Original file format

  • *.x3d (download the textures that are stored in separate files - the paths are specified inside x3d, usually just the file names = same directory)
    • to download a sample, visit 3d+map - open 3d scene then click the download button.

Programs

  • MeshLab
  • CloudCompare
  • Blender

Convert to other 3D formats

MeshLab

  • File > Export Mesh As... supports a few formats: *.3ds, *.ply, *.stl, *.obj, *.dxf, *.dae, *.xyz, etc.
    • *.x3d to *.obj:
      • there will be 2 files generated: *.obj and *.obj.mtl - the latter contains a list of texture files which should be kept around as well

Blender

  • Supports some x3d files but not all


View

MeshLab

  • Open *.x3d

Notes:

  • Lights off
  • Couldn't adjust proper camera settings

Blender

  • Convert to *.obj in MeshLab
  • File > Import > Wavefront (.obj)
  • Switch viewport shading to texture (in Default view it's located next to the Object mode)

CloudCompare

  • Convert to *.obj in MeshLab
  • Drag and drop *.obj into the CloudCompare window
  • Options > Display parameters > Colors and Materials > set all lights to white
  • Options > Camera parameters > set Camera/Eye center and fov