Difference between revisions of "Working with 3D models"

From ElphelWiki
Jump to: navigation, search
(Blender)
(Original file formats)
(5 intermediate revisions by the same user not shown)
Line 1: Line 1:
==<font color='blue'>Original file format</font>==
+
==<font color='blue'>Original file formats</font>==
* '''*.x3d''' (<font color='red'>download the textures that are stored in separate files</font> - the paths are specified inside x3d, usually just the file names = same directory)
+
* '''*.x3d'''
** to download a sample, visit [https://community.elphel.com/3d+map/ 3d+map] - open 3d scene then click the '''download''' button.
+
* '''*.obj''' wavefront
 +
 
 +
====Comments====
 +
* to download a model (x3d, obj and textures) visit [https://community.elphel.com/3d+map/ 3d+map] - open 3d scene then click the '''download''' button.
 +
* textures are '''*.png''' files are shared between x3d and obj
 +
* x3d - textures are listed inside
 +
* obj - textures are listed in an extra (material) file - '''*.mtl'''
 +
* most of the time textures will be located in the same dir
 +
* if downloading a model manually - do not forget textures (and a corresponding '''*.mtl''' for '''*.obj''')
  
 
==<font color='blue'>Programs</font>==
 
==<font color='blue'>Programs</font>==
Line 9: Line 17:
 
* Blender
 
* Blender
  
==<font color='blue'>Convert to other 3D formats</font>==
+
==<font color='blue'>Convert *.x3d to other 3D formats</font>==
 
===MeshLab===
 
===MeshLab===
 
* ''File > Export Mesh As...'' supports a few formats: '''*.3ds''', '''*.ply''', '''*.stl''', '''*.obj''', '''*.dxf''', '''*.dae''', '''*.xyz''', etc.
 
* ''File > Export Mesh As...'' supports a few formats: '''*.3ds''', '''*.ply''', '''*.stl''', '''*.obj''', '''*.dxf''', '''*.dae''', '''*.xyz''', etc.
Line 17: Line 25:
 
===Blender===
 
===Blender===
 
* Supports some x3d files but not all
 
* Supports some x3d files but not all
 
  
 
==<font color='blue'>View</font>==
 
==<font color='blue'>View</font>==

Revision as of 00:18, 3 August 2017

Original file formats

  • *.x3d
  • *.obj wavefront

Comments

  • to download a model (x3d, obj and textures) visit 3d+map - open 3d scene then click the download button.
  • textures are *.png files are shared between x3d and obj
  • x3d - textures are listed inside
  • obj - textures are listed in an extra (material) file - *.mtl
  • most of the time textures will be located in the same dir
  • if downloading a model manually - do not forget textures (and a corresponding *.mtl for *.obj)

Programs

  • MeshLab
  • CloudCompare
  • Blender

Convert *.x3d to other 3D formats

MeshLab

  • File > Export Mesh As... supports a few formats: *.3ds, *.ply, *.stl, *.obj, *.dxf, *.dae, *.xyz, etc.
    • *.x3d to *.obj:
      • there will be 2 files generated: *.obj and *.obj.mtl - the latter contains a list of texture files which should be kept around as well

Blender

  • Supports some x3d files but not all

View

MeshLab

  • Open *.x3d

Notes:

  • Lights off
  • Couldn't adjust proper camera settings

Blender

  • Convert to *.obj in MeshLab
  • File > Import > Wavefront (.obj)
  • Switch viewport shading to texture (in Default view it's located next to the Object mode)

CloudCompare

  • Convert to *.obj in MeshLab
  • Drag and drop *.obj into the CloudCompare window
  • Options > Display parameters > Colors and Materials > set all lights to white
  • Options > Camera parameters > set Camera/Eye center and fov